Advanced Search

Announcement

Collapse
No announcement yet.

Eclipse web not loading!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Eclipse web not loading!

    Experiencing an issue with loading Eclipse web? Here are a couple troubleshooting steps that can be checked:
    • Ensure the browser is Internet Explorer version 7.x - 11 32-bit
    • Add the Eclipse website address to the the Trusted Sites zone by going to Internet Options > Security > Trusted Sites > Sites. Then, add the website address, and click 'Add'. Next, please reload the website.
    • Ensure that the 'Enable Protected Mode' box is not selected for the Trusted Sites zones within the Internet Options of Internet Explorer.
    • Ensure that the security level for Trusted Sites zone is set to Medium defaults.
    • Try clearing the Application Cache. This can be done by closing Internet Explorer completely, then opening Command Prompt as an Administrator, and pasting the following command and hitting enter:
      • Code:
        rundll32 %windir%\system32\dfshim.dll CleanOnlineAppCache
      • Then, restart Internet Explorer and try accessing the Eclipse website.
    • Ensure .NET Framework 4.5 or above is installed. This can be checked when opening the Control Panel > Programs and Features. The installation must say .NET Framework 4.5 or above. If states client or profile in the entry name, please install .NET Framework 4.5. The download can be found at Microsoft's website: https://www.microsoft.com/en-us/down....aspx?id=30653
    • The minimum screen resolution should be set to 1280x1024 or greater.
    • Check to see if a proxy is enabled by going to Internet Options > Connections > LAN Settings. Ensure that 'Automatically detect settings' is enabled. If it is not, and a Proxy Server is being used, then please adjust the proxy server accordingly to allow connections to the Eclipse website.

    If anyone has any other steps they want to add, please feel free to reply to this post, as there are many different situations that could apply.

  • #2
    After browsing to the Eclipse URL I am greeted with an unhandled exception prior to log in:


    screenshot-1.png




    ERROR TEXT:
    An unhandled exception occurred, and the application is terminating. For more information, see your Application log. Exception Detail: Resolution of the dependency failed, type=
    "Eclipse.Controllers.UnhandledExceptionController", name = *(none)*.

    Exception occurred while: Calling constructor Eclipse.Controllers.UnhandledExceptionController(Microsoft.Practices.Unity.lUnityContainer container, Microsoft.Practices.Prism.PubSubEvents.lEventAggregator
    eventAggregator, Eclipse.Infrastructure.Interfaces.lDialogSetvice dialogService, Eclipse.Gateway.Interfaces.lErrorLogSer4ice errorLogService).

    Exception is: ResolutionFaileclException - Resolution of the dependency failed, type = "Eclipse.ViewModels.ExceptionDialogViewModel", name = *(none)*.
    Exception occurred while: while resolving.

    Exception is: ResolutionFaileclException - Resolution of the dependency failed, type = "Eclipse.Gateway.AuthorizationTokenHandler", name = *(none)*.
    Exception occurred while: while resolving.

    Exception is: AggregateException - One or more errors occurred.
    ...............................................
    Atthe time of the exception, the containerwas:

    Resolving Eclipse.Gateway.AuthorizationTokenHandler,(none)

    Resolving parameter "authClient" of constructor Eclipse.Gateway.AuthorizationTokenHandler(Eclipse.Gateway.Interfaces.lAuthRefreshClient authClient Eclipse.Service.ExternalGateways.Interfaces.lAuthToken authToken)
    Resolving Eclipse.Gateway.Interfaces.lAuthRefreshClient (none)

    Resolving Eclipse.ViewModels.ExceptionDialogViewModel,(none)

    Resolving parameter "reviewUserSessionManager" of constructor Eclipse.ViewModels.ExceptionDialogViewModel(Microsoft.Practices.Prism.PubSubEvents.lEventAggregator eventAggregator,
    Eclipse.Infrastructure.Interfaces.lReviewUserSessionManager reviewUserSessionManager, Eclipse.Infrastructure.Models.AppVersionlnfo versionlnfo)

    Resolving Eclipse.DataModel.Models.ReviewUserSessionManager,(none) (mapped from Eclipse.Infrastructure.Interfaces.lReviewUserSessionManager, (none))

    Resolving parameter "userSessionActivityProvider" of constructor Eclipse.DataModel.Models.ReviewUserSessionManager(Microsoft.Practices.Prism.PubSubEvents.lEventAggregator eventAggregator,
    Eclipse.Infrastructure.Interfaces.lUserSessionActivityProvider userSessionActivityProvider, Nucleus.Gateway.Interfaces.lReviewUserSessionGateway reviewUserSessionGateway,
    Eclipse.Gateway.Interfaces.SystemSetting.lSystemSettingGateway systemSettingsGateway, Eclipse.Infrastructure.Interfaces.lMessageBoxSeivice messageBoxService, Eclipse.Gateway.Interfaces.Cases.lCaseGateway caseGateway.
    Eclipse.DataModel.Interfaces.lSessionManager sessionManager, Eclipse.Infrastructure.Layout.lLayoutSetvice layoutService, Eclipse.Gateway.Interfaces.lAuthClient authClient Eclipse.DataModel.Interfaces.lSecuritySetvice
    securityService, Eclipse.Gateway.Interfaces.lUserSessionActivity userSessionActivity)

    Resolving Eclipse.DataModel.Models.UserSessionActivityProvider,(none) (mapped from Eclipse.Infrastructure.Interfaces.lUserSessionActivityProvider, (none))

    Resolving parameter "systemSettingGateway" of constructor Eclipse.DataModel.Models.UserSessionActivityProvider(Eclipse.Gateway.Interfaces.lUserSessionActivity userSessionActivity.
    Eclipse.Gateway.Interfaces.SystemSetting.lSystemSettingGateway systemSettingGateway)

    Resolving Eclipse.Gateway.SystemSetting.EclipseSystemSettingGateway,(none) (mapped from Eclipse.Gateway.Interfaces.SystemSetting.lSystemSettingGateway, (none))

    Resolving parameter "eclipseHttpSetvice" of constructor Eclipse.Gateway.SystemSetting.EclipseSystemSettingGateway(Eclipse.Gateway.Interfaces.lEclipseHttpService eclipseHttpService)
    Resolving Eclipse.Gateway.Interfaces.lEclipseHttpSeivice,(none)

    ...............................................
    Atthe time of the exception, the containerwas:

    Resolving Eclipse.Controllers.UnhandledExceptionController,(none)

    Calling constructor Eclipse.Controllers.UnhandledExceptionController(Microsoft.Practices.Unity.lUnityContainer container, Microsoft.Practices.Prism.PubSubEvents.lEventAggregatoreventAggregator,
    Eclipse.Infrastructure.Interfaces.lDialogSetvice dialogService, Eclipse.Gateway.Interfaces.lErrorLogSer4ice errorLogService)

    Solution:

    I was able to resolve the error by performing the following steps in this exact order:

    1. Delete temporary internet files and cookies
    2. Exit all Internet Explorer windows
    3. Launch CMD.EXE and run the following: rundll32 dfshim CleanOnlineAppCache
    4. Launch Internet Explorer and add site to trusted sites
    5. Connect to site
    6. Login success

    Comment

    Working...
    X